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Installation 
 
 
Before installing Linear Algebra Solved!, take a moment to review the system 
requirements.  It is always a good idea to make sure all other applications are 
closed while installing new software. 
 
 
System Requirements 
 
To use Linear Algebra Solved!, your computer must have one of the following 
Windows operating systems: 
 

� Windows 2000 
� Windows 2003 
� Windows XP 
� Windows Vista 

 
Installation of Linear Algebra Solved! is not supported on Windows 95/NT 4.x, 
Macintosh, or Linux computers. 
 
 
Install Linear Algebra Solved! 
 
You can install Linear Algebra Solved! from the CD or from the file that you 
downloaded. 
 
To install Linear Algebra Solved! 
 

1. Do one of the following: 
� If you are installing from a CD, insert the CD into the CD-ROM 

drive. 
� If you downloaded your copy of Linear Algebra Solved!, double-

click the file that you downloaded. 
 

2. In the Linear Algebra Solved! Setup Wizard window, click Next  to begin 
the installation. 

 
3. Read the License Agreement, select I Agree  and click Next .  If you 

decline, you cannot continue with the installation. 
 

4. Select a folder into which you want to install Linear Algebra Solved! and 
click Next . 
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5. All steps have now been completed, click Next  to confirm installation.  The 
progress bar tracks the progress of the installation. 

 
 
Sometimes a computer’s CD-ROM drive does not automatically run a CD. 
 
To start the installation from the CD 
 

1. On your desktop, double-click My Computer . 
2. In the My Computer window, double-click the icon for your CD-

ROM drive. 
3. In the list of files, double-click Setup.exe . 

 
 
Start Linear Algebra Solved! 
 
Once installed successfully, you can start Linear Algebra Solved! by double-
clicking the Linear Algebra Solved! icon on your desktop, or by clicking Start → 
All Programs → Bagatrix → Linear Algebra Solved! . 
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Getting Started 
 
 
This section contains information about starting Linear Algebra Solved! and the 
features that are available in the main window. 
 
 
Overview 
 
Many Linear Algebra Solved! features can be accessed from the main window.  
This is an overview of the basic setup: 
 

 
 
 
Main Toolbar 
 
The primary functions of Linear Algebra Solved! can be found on the Main 
Toolbar: 
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Notebook  – Creates a new Notebook, which will hold all of your problems, 
graphs, tests, documents, and tutorials.  When a Notebook is saved, all items in 
the notebook are saved. 
 
Problem  – Enter in your own problems, or view example problems.  The 
problems are then solved with step-by-step explanations. 
 
Graph  – Create graphs of your problems. 
 
Test  – Create printable tests, and also interactive multiple choice tests. 
 
Document  – Create a document using math symbols.  You can copy and paste 
your problems and tests directly into the document. 
 
Open  – Open your saved Notebooks. 
 
Save – Save the current Notebook, containing all your problems, graphs, tests, 
documents, and tutorials.  Settings are also saved in the Notebook. 
 
Print  – Prints the content of the current window. 
 
Sign In  – Multiple choice test data is saved when a student is signed in. 
 
Data – View test data of the student that is currently signed in. 
 
Web – Visit the Bagatrix website. 
 
 
Notebook 
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When you open a new problem, graph, test, or document, you create a new 
“notebook” to store everything in.  You can store as many of each items as you 
want in a notebook, and save the contents of the entire notebook by clicking on 
the Save icon on the Main Toolbar. 
 
 
Bagatrix Assistant 
 

 
 
The Bagatrix Assistant provides dynamic help topics, tutorials, and tips on the 
tasks you perform.  For example, the Assistant can explain why the input is 
invalid while entering a problem, and explain what is needed to make it correct.  
The Assistant also provides explanations on every step while solving problems, 
and links glossary terms used in the explanations.  You can hide/show the wizard 
by going to the menu and selecting Tools → Bagatrix Assistant . 
 
 
Notebook Explorer 
 

 
 
The Notebook Explorer lets you navigate through the problems, graphs, tests, 
and documents you currently have open.  You can rename the objects in your 
Notebook by clicking and highlighting them in the Notebook Explorer, then 
clicking on them again.  All items in the Notebook Explorer are saved when you 
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save a Notebook.  You can hide/show the Notebook Explorer by going to the 
menu and selecting Tools → Notebook Explorer . 
 
 
Help Contents 
 
The Help Contents panel provides categorized help topics and can be displayed 
on the left-hand side of the screen.  You can hide/show the Help Contents by 
going to the menu and selecting Help → Contents . 
 
 
Glossary 
 
The Glossary panel provides an alphabetized list of hundreds of mathematical 
terms, and can be displayed on the left-hand side of the screen with the 
Notebook Explorer and Help Topics.  You can select a term by double-clicking a 
word in the list, or typing it in by hand and pressing enter.  You can hide/show the 
Glossary by going to the menu and selecting Tools → Glossary . 
 
 
Calculator 
 
The Calculator can be displayed by going to the menu and selecting Tools → 
Calculator .  The Bagatrix Calculator only enables keys that can currently be 
pressed, and displays the entire expression in the Calculator display window.  To 
copy the expression, right-click on the Calculator display window and select 
Copy . 
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Entering a Problem 
 
 
Linear Algebra Solved! allows you to enter in your own problems, and provides 
step-by-step solutions.  To begin, click on the Problem  icon on the Main Toolbar, 
or go to the menu and select File → New → Problem . 
 
 
Problem Toolbar 
 

 
 
Answer  – Generates the step-by-step answer to the problem entered on the 
screen, using the method displayed in the Automatic Topic Selector. 
 
Example  – Enters an example problem onto the paper.  After clicking Example, a 
topic must be selected from the Select a Subject screen.  You can select the 
difficulty of the example problem on this screen as well.  The default difficulty can 
be set on the Options screen by right-clicking on the paper and selecting 
Options → All Options . 
 
Graph  – When this icon is enabled, you can graph the solution to the problem. 
 
Step  – Displays the next step in the problem solving process.  If the option Show 
Step-by-Step is selected, the Step button will move one step at a time.  If not, the 
entire problem will be displayed when the Step button is clicked. 
 
Note: When there are multiple papers on the screen, you can slide the pages by 
clicking and dragging them with the mouse.  You can quickly arrange the papers 
by right-clicking on a page and selecting Arrange papers .  You can also save a 
page as an image by right-clicking on a page and selecting Export Page Image . 
 
Insert  – Launches Quick Insert, a tool to insert various mathematical symbols 
and expressions into the problem. 
 
Erase  – Erases the problem and steps from the paper.  If Leave original problem 
is checked, only the steps are erased and the original problem is left on the 
screen. 
 
 
Automatic Topic Selector 
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When entering a problem, the topics that can be used to solve your problem are 
automatically displayed in the dropdown list.  You can click on the Topic Selector 
to select from the list of available topics.  
 
 
Using the Keyboard 
 
The following keys can be used to enter in your problems: 
 
Numbers:   0-9 
Letters (variables):  a-z 
Operators:   + (add) – (subtract) * (multiply) / (divide) 
Decimal Point: . 
Parenthesis:  ( ) 
Brackets:   [ ] 
Absolute Value:  | | 
Exponent:  ^  
Square Root:  ~ 
Equal Sign:   = 
Inequality Signs:  > (greater than) < (less than) 

>= (greater than or equal to) <= (less than or equa l to) 
 
Some Input Notes 
 

� To group multiple terms (such as in the numerator and/or denominator of 
a fraction), use parenthesis.  For example, (x+2)/3 will keep x+2 in the 
numerator, and ~(x+2) will keep x+2 under the square root symbol. 

� Outside parenthesis used to group multiple terms are not displayed on the 
screen.  For example, while you will need to input (x+2)/3 to keep x+2 in 
the numerator, it will display on the screen without the outside ( ) since 
they are not needed in the problem, and have no effect on the 
calculations. 

� Exponents can be entered without using ^ .  Entering 5x2 is the same as 
entering 5x^2 . 

� To enter in a variable following a fraction that you do not want in the 
denominator, use the multiplication symbol.  For example: 1/2*x.  Entering 
1/2x will place the x in the denominator. 

� To enter in problems such as Systems of Equations and Evaluating 
Variables, multiple lines of input are needed.  To insert a new line, click on 
Quick Insert  followed by New Line , or use the shortcut key: _.  

 
For example, to enter in a System of Equations, you can type: 
 
x+y=14 <Quick Insert → New Line>  2x+3y=35 
or 
x+y=14_2x+3y=35  
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For an Evaluating problem, you can enter: 
 
x+y+z <Quick Insert → New Line>  x=2 <Quick Insert → New Line>  
y=3 <Quick Insert → New Line>  z=4 
or 
x+y+z_x=2_y=3_z=4  
 
For a Point Slope problem, you can enter: 
 
(2,3) <Quick Insert → New Line>  m=2 
or 
(2,3)_m=2 
 
 

Quick Insert 
 

 
 
Quick Insert provides a method to quickly insert common math symbols and 
expressions into your problem.  Symbols and expressions include: 
 
Square Root, Nth Root, Fractions, Parenthesis, Brackets, Absolute Values, 
Exponents, Less Than or Equal To, Greater Than or Equal To, Pi, Division 
Symbol, and New Line. 
 
New Line 
 
The New Line button inserts a new line under the cursor on the paper.  Additional 
lines are needed when multiple items must be entered.  Systems of equations, 
evaluating, and point-slope problems are examples of problems requiring 
multiple lines of input. 
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Note: Where parentheses are shown on the Quick Insert buttons, parentheses 
are entered into the problem.  Parentheses used solely for grouping multiple 
terms in fractions, roots, etc., are not displayed on the screen during the solving 
process. 
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Creating a Graph 
 
 
Linear Algebra Solved! allows you to create detailed graphs of your problems.  
You can display an unlimited amount of graphs on the screen simultaneously.  
To begin, click on the Graph  icon on the Main Toolbar, or go to the menu and 
select File → New → Graph . 
 
 
Graph Toolbar 
 

 
 
Refresh  – Redraws the graph window using all the current settings. 
 
Zoom In  – Moves closer to the graph by shrinking the x and y axis ranges. 
 
Zoom Out  – Moves away from the graph by increasing the x and y axis ranges. 
 
Note: a specific region of the graph can be selected by clicking the graph window 
and dragging the mouse. 
 
Reset  – Sets the x and y axis range back to the default value. 
 
Insert  – Launches Quick Insert, a tool to insert various mathematical symbols 
and expressions into the problem. 
 
Erase  – Clears all objects from the graph. 
 
 
The Graph Cell 
 

 
 
To graph a problem, enter the problem into one of the graph cells.  There are ten 
graph cells available by default, but additional cells can be added by clicking on 
the triangle at the bottom of the last cell.  The color of the graph can be changed 
by clicking on the colored rectangle in the upper-right corner of the graph cell and 
selecting a new color.  There are also numerous options available by right-
clicking the graph cell with the mouse (including inserting various functions, 
calculating areas, and setting specific properties for each graph). 



 15 

 
 
Using the Keyboard 
 
Some of the problem types that can be graphed are: 
 
Points:  (1,2) 
Segments:  (1,2)-(3,4) 
Functions: f(x)=x2  
Equations: y=x2+3  
Inequalities: y>3x+2  
Conics: y2+x2=9 
 
The following keys can be used to create graphs: 
 
Numbers:   0-9 
Letters (variables):  x, y  
Operators:   + (add) – (subtract) * (multiply) / (divide) 
Decimal Point: . 
Parenthesis:  ( ) 
Brackets:   [ ] 
Absolute Value:  | | 
Exponent:  ^  
Square Root:  ~ 
Equal Sign:   = 
Inequality Signs:  > (greater than) < (less than) 

>= (greater than or equal to) <= (less than or equa l to) 
Other Functions: sin, cos, tan, sec, csc, cot, log, and ln (natural log)  
 
Some Input Notes 
 

� To group multiple terms (such as in the numerator and/or denominator of 
a fraction), use parenthesis.  For example, (x+2)/3 will keep x+2 in the 
numerator, and ~(x+2) will keep x+2 under the square root symbol. 

� Outside parenthesis used to group multiple terms are not displayed on the 
screen.  For example, while you will need to input (x+2)/3 to keep x+2 in 
the numerator, it will display on the screen without the outside ( ) since 
they are not needed in the problem, and have no effect on the 
calculations. 

� Exponents can be entered without using ^ .  Entering 5x2 is the same as 
entering 5x^2 . 

� To enter in a variable following a fraction that you do not want in the 
denominator, use the multiplication symbol.  For example: 1/2*x.  Entering 
1/2x will place the x in the denominator. 
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Quick Insert 
 

 
 
Quick Insert provides a method to quickly insert common math symbols and 
expressions into your problem.  Symbols and expressions include: 
 
Square Root, Nth Root, Fractions, Parenthesis, Brackets, Absolute Values, 
Exponents, Points, Segments, Less Than or Equal To, Greater Than or Equal 
To, Pi, and Division Symbol. 
 
Note: Where parentheses are shown on the Quick Insert buttons, parentheses 
are entered into the problem.  Parentheses used solely for grouping multiple 
terms in fractions, roots, etc., are not displayed on the screen during the solving 
process. 
 
 
Graph Features  
 
The graph also includes additional features: 
 

� Calculating Area 
 
You can calculate the area of equations and functions by right-clicking on 
the graph cell the problem is located and selecting Options → Area .  The 
Area screen lets you calculate the area and definite integral of the 
problem, and also lets you shade the region using the color of your choice.  
The integer area range can be set using the From and To fields.  The 
interval can also be set using the Interval field.  The smaller the interval, 
the more accurate the calculation will be (the interval must be larger than 
0 to calculate an area). 
 
The Area Screen: 
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� Evaluating f(x) 
 
You can evaluate functions by right-clicking on the graph cell the function 
is located and selecting Options → Evaluate f(x) .  The Evaluate f(x) 
screen lets you enter in a value for x to be substituted into the function.  
After you enter in a value for x and click the Evaluate f(x) button, you can 
click on the Insert Point button to insert the point into the current graph. 
 
The Evaluate f(x) Screen: 
 

 
 

� Exporting Graph Images 
 
You can export the current graph image by right-clicking on the graph 
window and selecting Export Graph Image .  You have the option of 
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exporting the file as a *.bmp, *.gif, *.jpeg, *.png, or *.tif file.  Once the 
graph image is exported and saved to your computer, you can import the 
image into most word processing programs.  You can also right-click on 
the graph window and select Copy Graph to Clipboard .  You can then 
open a word processing program and select Edit → Paste  to place the 
image directly into your document without saving the file. 
 

� Printing Blank Graph Paper 
 

To practice creating your own graphs by hand, you can print blank graph 
paper by right-clicking on the graph window and selecting Print Blank 
Graph Paper . 
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Taking a Test 
 
 
Linear Algebra Solved! allows you to create randomly generated standard and 
multiple choice tests.  To begin, click on the Test  icon on the Main Toolbar, or go 
to the menu and select File → New → Test . 
 
 
Test Toolbar 
 

 
 
 
Create  – Creates a test based on the selected subjects, number of problems, 
and difficulties selected. 
 
Subject  – Displays the Select a Subject screen, which allows you to select a 
subject to be added to the test.  The difficulty level of the subject can also be 
selected on the Select a Subject screen.  The default difficulty can be set on the 
Options screen by right-clicking the paper and selecting Options . 
 
View Test  – After a subject has been selected, and the Create button has been 
clicked, you can view the test.  This option creates a randomly generated test 
that can be printed.  The option to generate an answer sheet is also available. 
 
Multiple Choice  – After a subject has been selected, and the Create button has 
been clicked, you can create a multiple choice test.  This option creates a 
randomly generated test, and allows you to answer the questions by selecting 
one of the multiple choice answers.  Your test is then graded upon completion.  
The multiple choice test can also be printed, including an optional answer sheet. 
 
Erase  – Clears the entire contents of the test. 
 
Note: you can right-click on a created test and select Export to Document  to 
export the created test into a Math Document.
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Creating a Document  
 
 
Linear Algebra Solved! allows you to create documents using math notation and 
symbols found within the program.  You can use this feature to create custom 
assignments, quizzes, tests, handouts, and more.  To begin, click on the 
Document  icon on the Main Toolbar, or go to the menu and select File → New 
→ Document . 
 
 
Document Toolbar 
 

 
 
Edit  – Displays/hides the document Edit Window. 
 
Undo  – Undoes the last edit made to the document. 
 
Redo  – Redoes the last undo made to the document. 
 
Insert  – Launches Quick Insert, a tool to insert various mathematical symbols 
and expressions into the problem. 
 
Erase  – Clears the contents from the Edit Window. 
 
Color  – Sets the text color of the document. 
 
The font style and size can be set using the last two dropdown lists.  Typed Font 
is the default style, with Handwritten Font as an alternate style.  The default size 
of the font is 12, with options ranging from 8 to 16. 
 
 
Editing a Document  
 

 
 



 21 

The document can be edited by typing in the textbox, and converted into math 
notation by clicking on the yellow arrow underneath the textbox.  Some 
conversions occur automatically while entering text.  For example, 1/2 is 
automatically converted into fraction notation with the 1 over the 2 separated by a 
division line. 
 
Document Tips  
 

� Problems can be copied and pasted into the document.  After entering a 
problem in the Problem section, right-click on the paper and select Copy  
(you can select just the problem, answer, or all).  You can then move back 
to the open document, right-click on the Edit Window and select Paste  to 
insert the problem. 

� Tests can be exported into the document.  After creating a test in the Test 
section, click on the View Test or Multiple Choice button.  Next, right-click 
on the test and select Export to Document .  With the base test copied 
into the document, custom modifications can be made to suit your 
particular needs. 

 
Inserting Special Keys 
 
You can insert several special keys and text decorations by right-clicking on Edit 
Window and selecting Insert .  If text is highlighted while applying the insert, the 
highlighted text will be included (when applicable).  For example, if the text 2+3 is 
highlighted and you select Insert → Square Root , 2+3 will be replaced by 
Root[2+3] . 
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Student Data 
 
 
Linear Algebra Solved! allows you to save test data and chart progress.  To view 
student data, click on the Data icon on the Main Toolbar, or go to the menu and 
select Data → View .  You must be signed in to view student data. 
 
 
Student Management 
 
In order to save and view test data, you must first create a student.  If you have 
already created a student, you can sign in and continue. 
 
Creating a Student 
 
To create a student, go to the menu and select Data → Create Student . 
 

 
 
You can create a unique student name up to 50 characters long.  After entering 
the name, click the Create Student button. 
 
Deleting a Student 
 
To delete a student, go to the menu and select Data → Delete Student .  You 
can then select the student you would like to delete from the dropdown list. 
 
Signing In 
 
To sign in under one of the previously created students, click the Sign In  button 
on the Main Toolbar, or go to the menu and select Data → Sign In .  If someone 
is currently signed in, the Sign In button on the toolbar will be switched to a Sign 
Out button. 
 
Once signed in, your student name will appear in the upper-right corner of the 
screen next to a green light: 
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Signing Out 
 
To sign out, go to the menu and select Data → Sign Out . 
 
 
Creating Data 
 
Once you are signed in, you can begin creating student data.  To create data, 
click on the Test  icon on the Main Toolbar, or go to the menu and select New → 
Test .  Next, select a subject by clicking the Subject button then create the test by 
clicking the Create button (only one subject is allowed per test when signed-in).  
After the test is created, click the Multiple Choice button.  When you are signed 
in, all multiple choice test scores are saved under your student name. 
 
Note: The multiple choice test has an orange header when you are signed in. 
 

 
 
When you are finished answering the multiple choice test, click on the Finish  
button to receive your score and save your data. 
 
 
Viewing Data 
 
Once you are signed in and have taken at least one multiple choice test, you can 
view your data.  To view data, click on the Data icon on the Main Toolbar, or go 
to the menu and select Data → View . 
 
The Student Data screen displays all of your scores along with a chart.  There 
are several features available on the Student Data screen, including: 
 

� Regression  – A regression line is drawn on the chart, which shows the 
general trend of your scores.  If your scores are increasing, the line will 
slope upwards and be colored green.  If your scores are decreasing, the 
line will slope downwards and be colored red.  You can show/hide the 
regression line by right-clicking on the chart and selecting Show 
Regression. 

� Average  – Your current average is displayed above the chart.  You can 
also draw the average on the chart, represented by a blue line.  You can 
show/hide the average line by right-clicking on the chart and selecting 
Show Average. 
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The Student Data Screen: 
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Options 
 
 
Linear Algebra Solved! offers several options for using the software.  To view the 
Option Screen, go to the menu and select Tools → Options . 
 

 
 
 
Problem Options 
 
Show Step-by-Step  – Shows the solution to the problem one step at a time.  If 
not checked, every step of the problem is displayed to the screen the first time 
you click the Next button on the Problem toolbar. 
 
Show Explanations on Paper  – Shows the step explanations on the paper. 
 
Show Pencil  – Shows a pencil writing the problem you are typing. 
 
Step Detail Level  – The amount of detail shown in the steps.  The higher the 
detail, the more steps are shown on the paper while solving. 
 
Example Difficulty  – The default difficulty level when inserting example 
problems. 
 
Rounding Digits  – The number of digits to use if a calculation must round a 
number. 
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Graph Options 
 
Background  – Selects the background of the grid.  The options are Automatic 
(the software chooses the best background depending on the graph), Cartesian, 
Polar, and None. 
 
Color  – The color used to display the grid. 
 
Shade – Shades the graph.  When printing the graph, it is good to turn this 
option off to preserve printer ink. 
 
Graph Label  – Selects the Axis to label.  The options are Automatic, X/Y Axis, 
All X, All X/Y, or None. 
 
Increment  – The size of the squares on the display grid. 
 
Pi-Based X-Axis  – Displays the x-axis in terms of Pi. 
 
Quadrants  – Labels all four quadrants. 
 
Intersections  – Displays the point(s) of intersection of all items currently on the 
graph (not including points and segments). 
 
X/Y Axis  – Displays black lines at x=0 and y=0, intersecting at the origin. 
 
Rounding Digits  – The number of digits to use if a calculation must round a 
number. 
 
 
Test Options 
 
Problem Difficulty  – The default difficulty level when selecting subjects for the 
test. 
 
Multiple Choice Options  – The maximum number of multiple choice answers 
available when taking a multiple choice test. 
 
Font – The font style used when creating the tests. 
 
Font Size  – The font size used when creating the tests. 
 
 
Data Options 
 
Data Mode  – The mode used to display the data. 
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Bar Graph Color  – If the Data Mode is set to Bar Graph, this is the color used to 
display the bars. 
 
Show Scale  – Displays the vertical grading scale (0-100). 
 
Label Points  – Labels the points for all data modes except Bar Graph mode. 
 
Show Regression  – Draws a regression line on the chart, displaying the general 
trend of the scores.  If the trend is increasing, the regression line is green and 
slopes upward.  If the trend is decreasing, the regression line is red and slopes 
downward. 
 
Show Grid  – Displays the horizontal grid on the chart. 
 
Show Average  – Draws a blue line on the chart displaying the average score of 
the data. 


